Need help repairing a wii

link2702

Smash Champion
Joined
May 10, 2008
Messages
2,083
Location
Oklahoma
#1
Sorry if this isn’t the right area, but anyway...

Basically I found my original wii, took it apart to clean it and afterwards found the system would not spin any discs(I don’t think it did years ago when I transferred everything to wii u just didn’t care enough then, nor did I have the tools to take it apart), it just makes 3 clicking noises then says it cannot read the disc.

I took it apart again to disassemble the entire disc drive and see if maybe I could fix the issue by a deeper cleaning with compressed air and just see if something like a motor or gear showed visible signs of being burned out or broken, nothing seemed out of place...


...but while i was doing that, 3 identical size springs fell out from...somewhere, and now I can’t put it back together unless I figure out where those springs go.

I know I could just buy a new drive, and probably should anyway, but considering I did this also as a learning experience, I kinda want to see if I can get this old one working, or least learn how it worked. But I’m stumped at this point, I cannot figure out where these springs go at all.

So has anyone else attempted this and if so can you post a picture of where the springs go? Also does anyone know the exact reason why it won’t spin the disc at all? I figured it’d be some kind of motor, but wouldn’t that show actual signs of damage?
 

link2702

Smash Champion
Joined
May 10, 2008
Messages
2,083
Location
Oklahoma
#2
Sorry to bump this again but...

I ended up getting a replacement drive, my old wii now works....

Now though I’ve got another question... I bought another wii at goodwill for cheap. Didn’t fully test it there though...just made sure it powered on and the disc reader worked (an extra backup basically.)

But this one constantly gives an error that the system files are corrupt. I did some research and learned it dealt with something on the message board, and starting in maintenance mode would let you get it working...

...I didn’t read on till it was too late, to not reformat it, as then the problem would happen when restarting the console and you’d be stuck during the setup process...

Does anyone know how to fix this? I’d like to get this wii console back up and running if possible. While it’s not the end of the world if i can’t since my original is back up, I’d still not up and abandon this one completely yet.
 
Top