Lag issue finally SOLVED!!

Steelmullet

Smash Apprentice
Joined
Oct 21, 2005
Messages
92
Guys I have been a long time advocate of how bad the lag is in SMASH ULTIMATE, but today I have finally figured out what was actually wrong.

Two things so no wonder it was hard to figure out.

1. My NAT was sometimes D and B. Nat A is the best. Do not let anyone tell you blah blah it's fine with Nat B or some crap, Nat A solved almost ALL of my lag issues instantly. So if you have a lower NAT than A, look online for tutorials.

Changing MTU settings is ASS. All that does is create more in game input lag. At ;east with some ISPs and modems.

And finally, the second issue, which most likely is just my experience. My Switch OVERHEATS. When it overheats, I get dropped button inputs and about 0.5 seconds of input lag if the input does go through.

I have to have an air conditioner blow into my switch while playing.

So there you have it. The mystery for me is finally solved. Changing my NAT to A and keeping my switch way past cool fixed all my issues. :)
 
Last edited:

Steelmullet

Smash Apprentice
Joined
Oct 21, 2005
Messages
92
Oh well all good things must come to an end.

The new online update borked it all up again. I had been playing perfectly fine matches for almost 1 month. Not 100% but it brought back memories of how fun the game could potentially be.

Alas, whatever happened with the new update has ruined online for me. It's even worse than before. So bye bye smash bros ultimate.
 

Homeboi

Smash Cadet
Joined
May 6, 2020
Messages
32
Oh. Well ive hosted tournaments every week and i am active in the community and i have no lag problem. Maybe i have amazing wifi i dont know but i havent had an issue with it. and stuff like input delay is basically forced but only for a few frames.
 

Steelmullet

Smash Apprentice
Joined
Oct 21, 2005
Messages
92
Oh. Well ive hosted tournaments every week and i am active in the community and i have no lag problem. Maybe i have amazing wifi i dont know but i havent had an issue with it. and stuff like input delay is basically forced but only for a few frames.
How lucky...

95% of my online matches are terrible now. I have played with other internet connections too, 5g, 2.4g, wired to no avail. If i didn't know any better, I'd think nintendo specifically programmed 0.5 seconds of input lag into my switch with the newest update. Ha. Obvi that isn't the case. :p

Maybe I should get whatever internet the majority of people are using. Some sort of ISP discrimination or something.
 
Top Bottom